Меню

Openwrt как настроить билайн

l2tp на OpenWRT

Рекомендованные сообщения

Jesprit 0

Jesprit 0

  • Новичок
  • Посетитель
  • 0
  • 7 публикаций
  • Пол: Мужчина

Два дня уже потратил на попытки настроить l2tp на OpenWRT.

Понял что скорее всего снова придется пересобирать прошивку, дабы включить туда kmod-pppol2tp, но хотелось бы быть уверенным что это так. Роутер уже настроен и все заново настраивать не хочется.

Так вот хотелось бы увидеть понятный и актуальный (http://downloads.openwrt.org/snapshots/trunk/) мануал без всяких гуи, просто через ssh.

Кто уже для себя настроил выкладывайте конфиги.

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

VladimirSS 3

VladimirSS 3

  • Гуру форума
  • Модератор
  • 3
  • 7 321 публикация
  • Пол: Мужчина
  • Откуда: [NGZ]

Два дня уже потратил на попытки настроить l2tp на OpenWRT.

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Pilot6 45

Pilot6 45

  • Местный
  • Посетитель
  • 45
  • 278 публикаций
  • Пол: Мужчина
  • Откуда: Москва

Два дня уже потратил на попытки настроить l2tp на OpenWRT.

Понял что скорее всего снова придется пересобирать прошивку, дабы включить туда kmod-pppol2tp, но хотелось бы быть уверенным что это так. Роутер уже настроен и все заново настраивать не хочется.

Так вот хотелось бы увидеть понятный и актуальный (http://downloads.openwrt.org/snapshots/trunk/) мануал без всяких гуи, просто через ssh.

Кто уже для себя настроил выкладывайте конфиги.

Не надо ничего пересобирать. Пакет можно поставить и потом. Я выкладывал подробный мануал со скриптами по настройке openl2tp для Билайна форуме ixbt в теме про tp-link 1043.

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Jesprit 0

Jesprit 0

  • Новичок
  • Посетитель
  • 0
  • 7 публикаций
  • Пол: Мужчина

Наверно да, но требует kmod-pppol2tp и при

говорит что у меня стоит kmod-pppoe и ставиться не будет. Как я понял там надо собирать прошивку.

Не надо ничего пересобирать. Пакет можно поставить и потом. Я выкладывал подробный мануал со скриптами по настройке openl2tp для Билайна форуме ixbt в теме про tp-link 1043.

Какой\ие пакет\пакеты требуются для работы скрипта openl2tpd?

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

VladimirSS 3

VladimirSS 3

  • Гуру форума
  • Модератор
  • 3
  • 7 321 публикация
  • Пол: Мужчина
  • Откуда: [NGZ]

Какой\ие пакет\пакеты требуются для работы скрипта openl2tpd?

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Jesprit 0

Jesprit 0

  • Новичок
  • Посетитель
  • 0
  • 7 публикаций
  • Пол: Мужчина

все не то. но спасибо за помощь.

Разобрался, спасибо Pilot6

ну и более ли менее свежий скрипт и конфиги прикрепляю сюда.

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Pilot6 45

Pilot6 45

  • Местный
  • Посетитель
  • 45
  • 278 публикаций
  • Пол: Мужчина
  • Откуда: Москва

Наверно да, но требует kmod-pppol2tp и при

говорит что у меня стоит kmod-pppoe и ставиться не будет. Как я понял там надо собирать прошивку.

Не надо пересобирать.

Не надо ничего пересобирать. Пакет можно поставить и потом. Я выкладывал подробный мануал со скриптами по настройке openl2tp для Билайна форуме ixbt в теме про tp-link 1043.

Какой\ие пакет\пакеты требуются для работы скрипта openl2tpd?

Пакет нужен openl2tp, а остальные там сами должны встать. kmod-pppol2tp, portmap, libncurses, libreadline

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Dimony4 0

Dimony4 0

  • Новичок
  • Посетитель
  • 0
  • 17 публикаций
  • Пол: Не определился

Pilot6, а какая последняя сборка Вами выложена?

С 26806, которую нашел, подружиться не удалось, так как не давала изменить пароль для рута и включить SSH, а как следствие не удалось поднять l2tp.

Релиз 27608 тоже бесполезен без инета, так там нет предустановленного l2tp модуля.

В итоге откатился на 820 официальную прошифку.

Попробовал пошаманить: поставил версию с сайта, авторизовался, накатил версию от Pilot6, прописал конфиги.

L2TP подымается через 5 минут после запуска роутера, потом работает 6 часов и отваливается. Перезапуск openl2tp не спасает отца русской демократии. Пишет только, что сам загрузился и ничего не делает. Мягкий ребут тоже не помогает, только вырубание питалова. Почему так, хз.

Читайте также:  Как настроить часы suunto core

Опять откатился на штатную 820.

Попробую на достуге пошаманить с xl2tpd.

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Pilot6 45

Pilot6 45

  • Местный
  • Посетитель
  • 45
  • 278 публикаций
  • Пол: Мужчина
  • Откуда: Москва

Pilot6, а какая последняя сборка Вами выложена?

С 26806, которую нашел, подружиться не удалось, так как не давала изменить пароль для рута и включить SSH, а как следствие не удалось поднять l2tp.

Релиз 27608 тоже бесполезен без инета, так там нет предустановленного l2tp модуля.

В итоге откатился на 820 официальную прошифку.

Попробовал пошаманить: поставил версию с сайта, авторизовался, накатил версию от Pilot6, прописал конфиги.

L2TP подымается через 5 минут после запуска роутера, потом работает 6 часов и отваливается. Перезапуск openl2tp не спасает отца русской демократии. Пишет только, что сам загрузился и ничего не делает. Мягкий ребут тоже не помогает, только вырубание питалова. Почему так, хз.

Опять откатился на штатную 820.

Попробую на достуге пошаманить с xl2tpd.

Я постоянно выкладываю сборки. Вот вчера выложил RC5 и транк свежий, но хорошо потестированный.

По поводу невозможности изменить пароль — извините тут дело в кривых руках, больше не в чем.

Источник



Openwrt как настроить билайн

1) Скачать образ загрузчика.
2) Скачать прошивку.
3) Скачать Telnet client и TFTP клиент.
4) Зайти в роутер как супер пользователь. Для этого
для прошивки версий младше 2.0.25:
Имя пользователя: SuperUser
Пароль: Beeline$martB0x
——————————
для прошивок начиная с 2.0.25 (за информацию спасибо пользователю Bomrin с forum.ixbt.com)
Имя пользователя: SuperUser
Пароль: SFXXXXXXXXXX (серийный номер устройства, указан на наклейке сзади устройства)
5) Затем жмем Расширенные настройки -> Другие -> Контроль доступа
Ставим галочку в пункте TELNET Admin : Разрешить для LAN
Жмем Сохранить, после Применить.
Перезагружаем роутер и идём дальше.
6) Подключаемся по Telnet и сливаем бэкап текущей прошивки.
Запускаем Putty и вводим следующие настройки (IP 192.168.1.1, Telnet)
3Жмем Open. В открывшемся окне вводим логин и пароль аналогичные тем, что вы использовали на первом пункте (SuperUser:SF********)
7) Вбиваем sh
8) Делаем бэкап прошивки на Flashку:
cd /mnt/shares/A
mkdir mtd_backup
cd mtd_backup
dd if=/dev/mtdblock0 of=mtd0
dd if=/dev/mtdblock1 of=mtd1
dd if=/dev/mtdblock2 of=mtd2
dd if=/dev/mtdblock3 of=mtd3
dd if=/dev/mtdblock4 of=mtd4
dd if=/dev/mtdblock5 of=mtd5
dd if=/dev/mtdblock6 of=mtd6
dd if=/dev/mtdblock7 of=mtd7
dd if=/dev/mtdblock8 of=mtd8
dd if=/dev/mtdblock9 of=mtd9
dd if=/dev/mtdblock10 of=mtd10

cd /
/etc.ro/usb/usb_u.sh
9) sc_flash -w 1ffa0 -o 30
sc_flash -w 1ffa1 -o 31
sc_flash -w 1ffa2 -o 30
sc_flash -w 1ffa3 -o 33
проверяем: sc_flash -r 1ffa0 -c 4 должно выдать 30 31 30 33 . Очень важно!

10) Переходим в админ-панель устройства
Расширенные настройки -> Другие -> Обновление ПО
Выбираем образ загрузчика bootloader_smartbox-to-boot_97d.img и жмём Выполнить обновление.
Через 3-7 загрузчик минут зашьется и роутер перезагрузится. Вы это поймете по загоревшимся светодиодам на передней панели.
11) Соединяем патчкордом ПК и роутер (Внимание, втыкаем в роутере в первый (LAN1) СЕРЫЙ порт, а не красный).
Прописывем на сетевой карте статический IP 192.168.1.10, шлюз 192.168.1.6
12) Отключить фаирвол (перед загрузкой файла в роутер по FTP).
13) Затем запускаем TFTP клиент, вбиваем IP 192.168.1.6, выбираем файл прошивки N300_1.2.bin и жмем Upgrade. Ждем очень много времени . не переживаем . ждем .
(Если, вдруг, загрузка не происходит, то выключаем роутер, зажимаем reset, включить удерживая reset секунд 15 и пробуем повторно).
14) Ставим DHCP. Роутер раздаст IP адреса.
15) Затем по SSH (или Telnet по вашему желанию) подключаемся к роутеру (для Windows я рекомендую Bitvise SSH Client) и вбиваем к консоли.
mtd erase rootfs_data

Роутер: Beeline SmartBox N300.
Процессор: Realtek RTL8197D (660 MHz)
Flash память: 16 Мб (Winbond W25Q128FVSG)
Оперативная память: 64 Мб (EtronTech EM6AB160TSD-5G)
WiFi модуль: Realtek RTL8192CE 802.11bgn 2T2R
USB 2.0 — есть 1.
LAN — 4 шт. (100 Мб/с)
WAN — 1 шт. (100 Мб/с)
JTAG — есть, 12-pin. J21 разъем. (Для прошивки)
Serial Port — есть, 4-pin. J22 разъем. (Для доступа к консоли) на скорости 38400, 8, N, 1

Читайте также:  Вкладки в гугл хром списком как настроить

Как создать интерфейс для модема huawei(hilink)
Характеристики сабжа на WikiDevi
Beeline Smart Box – брендовый роутер провайдера Beeline изначально предназначенный для работы только в сетях Beeline. Сам роутер производится компанией Sercomm в Тайвани по заказу компании Beeline. В основе роутера лежит референс-плата на основе Realtek 8197D. В роутере имеется поддержка IPTV и возможность использовать его как сетевое хранилище.

В теме нет куратора. По вопросам наполнения шапки обращайтесь к автору в QMS или к модераторам раздела через кнопку под сообщениями. Как это сделать правильно, что бы вас поняли с первого раза, хорошо описано здесь .

Сообщение отредактировал Djeclol — 20.11.20, 14:13

Источник

Всего по немногу

Настройка L2TP-соединения на OpenWRT для интернет Beeline Казахстан

  • Получить ссылку
  • Facebook
  • Твиттер
  • Pinterest
  • Электронная почта
  • Другие приложения

Подключил я значит интернет от Билайна. Мне пришли техники и поставили роутер TL-WR740N Ver.:6.0. Сидел и думал, а не прошить ли мне его. Подумал и решился, пошел гуглить. Хотел сначала поставить dd-wrt, но для данной версии на официальном сайте не оказалось, только до версии Ver.:4.x. Стал искать дальше и нашел прошивку от OpenWRT для Ver.:6.0. Скачал прошивку для этой модели и версии. Прошивка squashfs-factory.

После обновления я столкнулся с проблемой, у меня не поставился WEB интерфейс. Как оказывается в самом роутере настолько урезали память, что ее не хватает на установку WEB интерфейса. Еще выяснилось, что в стандартной сборке отсутствуют модули для установления L2TP-соединения. Поэтому настоятельно рекомендую загрузить установочные пакеты (с зависимостями) заранее вручную. Скачиваем все ниже перечисленное в отдельную папку на ПК.

С помощью программы WinSCP заходим на роутер. Протокол передачи выбираем «SCP», логин: root, пароль: без пароля. Далее поднимаемся на уровень выше по каталогу и переходим в паку /tmp и туда копируем выше скачанные файлы.
Затем запускаем программу Putty, подключаемся через нее к нашему роутеру. Переходим в папку /tmp.

Открываем файл network текстовым редактором vi. Заранее посмотрите в интернете как пользоваться текстовым редактором vi.

Добавляем в config interface ‘wan’ параметр: option reqopts ‘routes msstaticroutes’. Вот как будет выглядеть.

config interface ‘wan’
option ifname ‘eth1’
option proto ‘dhcp’
option reqopts ‘routes msstaticroutes’

Ниже добавляем новый конфиг для нашего Билайн и сохраняем. Здесь указываем ваш логин и пароль от Билайна. Все это сохраняем.

config interface ‘beelinekz’
option proto ‘l2tp’
option server ‘l2tp.internet.beeline.kz’
option username ‘логин’
option password ‘пароль’
option keepalive ’20 5′
option defaultroute ‘1’

Перезагружаем службу network.

Теперь нужно проверить поднялось ли наше соединение.

Должно в списке появиться l2tp-beelinekz, если не появилось, то проверьте все ли ввели верно.

l2tp-beelinekz Link encap:Point-to-Point Protocol
inet addr:5.34.20.32 P-t-P:77.74.65.242 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1460 Metric:1
RX packets:438372 errors:0 dropped:0 overruns:0 frame:0
TX packets:391889 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:291880224 (278.3 MiB) TX bytes:194568451 (185.5 MiB)

Теперь нужно заставить, чтобы интернет раздавался на устройства в локальной сети, для этого открываем firewall.

Правим config zone wan, приводим в такой вид и сохраняем.

config zone
option name wan
list network ‘beelinekz’
list network ‘wan6’
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1

Перезагружаем наш firewall.

После этого можно проверить интернет на компе. Далее настраиваем wi-fi.

Приводим его в такой вид и сохраняем.

config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path ‘platform/qca953x_wmac’
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

Читайте также:  Леново как настроить погоду

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Wi-Fi #здесь указываете название сети
option encryption psk2
option key password #пароль от сети Wi-Fi

Перезагружаем службу network.

Подключаемся к вашей сети Wi-Fi и проверяем интернет. После всех манипуляций перезагружаем роутер.

Источник

Openwrt как настроить билайн

1) Скачать образ загрузчика.
2) Скачать прошивку.
3) Скачать Telnet client и TFTP клиент.
4) Зайти в роутер как супер пользователь. Для этого
для прошивки версий младше 2.0.25:
Имя пользователя: SuperUser
Пароль: Beeline$martB0x
——————————
для прошивок начиная с 2.0.25 (за информацию спасибо пользователю Bomrin с forum.ixbt.com)
Имя пользователя: SuperUser
Пароль: SFXXXXXXXXXX (серийный номер устройства, указан на наклейке сзади устройства)
5) Затем жмем Расширенные настройки -> Другие -> Контроль доступа
Ставим галочку в пункте TELNET Admin : Разрешить для LAN
Жмем Сохранить, после Применить.
Перезагружаем роутер и идём дальше.
6) Подключаемся по Telnet и сливаем бэкап текущей прошивки.
Запускаем Putty и вводим следующие настройки (IP 192.168.1.1, Telnet)
3Жмем Open. В открывшемся окне вводим логин и пароль аналогичные тем, что вы использовали на первом пункте (SuperUser:SF********)
7) Вбиваем sh
8) Делаем бэкап прошивки на Flashку:
cd /mnt/shares/A
mkdir mtd_backup
cd mtd_backup
dd if=/dev/mtdblock0 of=mtd0
dd if=/dev/mtdblock1 of=mtd1
dd if=/dev/mtdblock2 of=mtd2
dd if=/dev/mtdblock3 of=mtd3
dd if=/dev/mtdblock4 of=mtd4
dd if=/dev/mtdblock5 of=mtd5
dd if=/dev/mtdblock6 of=mtd6
dd if=/dev/mtdblock7 of=mtd7
dd if=/dev/mtdblock8 of=mtd8
dd if=/dev/mtdblock9 of=mtd9
dd if=/dev/mtdblock10 of=mtd10

cd /
/etc.ro/usb/usb_u.sh
9) sc_flash -w 1ffa0 -o 30
sc_flash -w 1ffa1 -o 31
sc_flash -w 1ffa2 -o 30
sc_flash -w 1ffa3 -o 33
проверяем: sc_flash -r 1ffa0 -c 4 должно выдать 30 31 30 33 . Очень важно!

10) Переходим в админ-панель устройства
Расширенные настройки -> Другие -> Обновление ПО
Выбираем образ загрузчика bootloader_smartbox-to-boot_97d.img и жмём Выполнить обновление.
Через 3-7 загрузчик минут зашьется и роутер перезагрузится. Вы это поймете по загоревшимся светодиодам на передней панели.
11) Соединяем патчкордом ПК и роутер (Внимание, втыкаем в роутере в первый (LAN1) СЕРЫЙ порт, а не красный).
Прописывем на сетевой карте статический IP 192.168.1.10, шлюз 192.168.1.6
12) Отключить фаирвол (перед загрузкой файла в роутер по FTP).
13) Затем запускаем TFTP клиент, вбиваем IP 192.168.1.6, выбираем файл прошивки N300_1.2.bin и жмем Upgrade. Ждем очень много времени . не переживаем . ждем .
(Если, вдруг, загрузка не происходит, то выключаем роутер, зажимаем reset, включить удерживая reset секунд 15 и пробуем повторно).
14) Ставим DHCP. Роутер раздаст IP адреса.
15) Затем по SSH (или Telnet по вашему желанию) подключаемся к роутеру (для Windows я рекомендую Bitvise SSH Client) и вбиваем к консоли.
mtd erase rootfs_data

Роутер: Beeline SmartBox N300.
Процессор: Realtek RTL8197D (660 MHz)
Flash память: 16 Мб (Winbond W25Q128FVSG)
Оперативная память: 64 Мб (EtronTech EM6AB160TSD-5G)
WiFi модуль: Realtek RTL8192CE 802.11bgn 2T2R
USB 2.0 — есть 1.
LAN — 4 шт. (100 Мб/с)
WAN — 1 шт. (100 Мб/с)
JTAG — есть, 12-pin. J21 разъем. (Для прошивки)
Serial Port — есть, 4-pin. J22 разъем. (Для доступа к консоли) на скорости 38400, 8, N, 1

Как создать интерфейс для модема huawei(hilink)
Характеристики сабжа на WikiDevi
Beeline Smart Box – брендовый роутер провайдера Beeline изначально предназначенный для работы только в сетях Beeline. Сам роутер производится компанией Sercomm в Тайвани по заказу компании Beeline. В основе роутера лежит референс-плата на основе Realtek 8197D. В роутере имеется поддержка IPTV и возможность использовать его как сетевое хранилище.

В теме нет куратора. По вопросам наполнения шапки обращайтесь к автору в QMS или к модераторам раздела через кнопку под сообщениями. Как это сделать правильно, что бы вас поняли с первого раза, хорошо описано здесь .

Сообщение отредактировал Djeclol — 20.11.20, 14:13

Источник